Svenska 3D-Tåg - Forum  
 

Om det här är ditt första besök, se till att gå till vår FAQ (finns även länk till FAQ i navigeringsmenyn ovan). Du kan behöva att registrera dig innan du kan posta (finns även en länk till registrering i navigeringsmenyn ovan). För att titta på inlägg, välj det forum som du vill besöka från de som är listade nedan.

Gå tillbaka   Svenska 3D-Tåg - Forum > Auran Trainz > Scenarios och scripts

Svara
 
Ämnesverktyg Visningsalternativ
Gammal 2016-05-21, 15:49   #1
Nils Blid
Medlem
 
Reg.datum: Dec 2009
Ort: Malmö
Inlägg: 2 026
Standard Tji SignalMarker i TANE

För ett par dagar sedan slog jag larm om att dvärgsignalerna inte fungerar i TANE. Inlägget föranledde ingen kommentar, varför jag drar slutsatsen att ingen annan i Forum laborerar med STL.s nya Moderna ljussuignaler. Kanske är jag en ofrivillig betatestare.

Dessvärre ser det ut som om SignalMarker (SM) inte fungerar i TANE i versionen Moderna ljussignaler. SM läggs ju in för att styra infartssignalen och ge rätt signalbesked. I infartssignalens propertyruta (Osynlig master) möts man av svärta och inget annat..

Men minimappen är färgrik värre. I den visas SM som kraftfullt rödmarkerat. Normalt visas inte SM i minimappen.

Nisse
Bifogade bilder
Filtyp: jpg SM.jpg (206.1 KB, 77 visningar)
Nils Blid besöker inte forumet just nu  
Svara med citat
Gammal 2016-05-21, 19:07   #2
korvtiger
Medlem
 
Reg.datum: Jan 2008
Ort: Östergötland, Sverige
Inlägg: 2 483
Standard

För det första ska man i regel aldrig använda SMs i det moderna signalsystemet. Dessa SMs är till för att referera tågvägar i det äldre systemet och behövs ytterst sällan i det moderna systemet då man istället refererar till mellansignaler som alltid ska finnas.

För det andra, om det är infartssignalens propertyruta som är tom (Signal egenskaper: UNASSIGNED) så beror det på att den inte kopplat sig korrekt med scenery-signalen. Har ingenting med SMs att göra. Kontrollera namngivningen på både mastern och scenery-signalen och se att de är exakt samma förutom att scenerysignalen har parentes. Ser på din karta att du blandar stora och små bokstäver. Scriptet anser att Hnd och hnd är två helt olika tpl-signaturer, så använd alltid små bokstäver i dessa signturer!

Signal markers är vanliga trackmarks och visas därför (och har alltid visats) som röda trianglar på kartan, inget konstigt där.
__________________
-k-

Senast redigerad av korvtiger den 2016-05-21 klockan 19:10.
korvtiger besöker inte forumet just nu   Svara med citat
Gammal 2016-05-22, 17:47   #3
Nils Blid
Medlem
 
Reg.datum: Dec 2009
Ort: Malmö
Inlägg: 2 026
Standard

Korvtigers inlägg ovan föranledde åtgärder. Har gått igenom Nynäsbanans samtliga stationer (ej Älvsjö och Centralen). Resultaten blev förbluffande – närmast sensationella:

Samtliga ljussignaler rätt konfigurerade/inskrivna.

Samtliga mellansignaler hade felaktigt försetts med inledande stor bokstav - ex. ”Tåd 22” istället för ”tåd 22”.

80 procent av övriga signaler – infart, stoppsignaler etc – rätt konfigurerade.

Testade infartssignalens propertyruta och Välj signal. Inget innehåll.

Alla felaktigheter åtgärdades och sparades. Gick ut ur TANE och startade om. Dom felaktiga stora bokstäverna kom tillbaka.

En anledning kan vara att jag inte tagit bort bocken för ”Tpl signatur = Signal XXXX” i masterns propertyrutDet bör påpekas att jag lagt om bansträckningen från jämn till udda samt ändrat Jglokets signaler till Svenolovs.

Nisse
Nils Blid besöker inte forumet just nu   Svara med citat
Svara

Ämnesverktyg
Visningsalternativ

Regler för att posta
Du får inte posta nya ämnen
Du får inte posta svar
Du får inte posta bifogade filer
Du får inte redigera dina inlägg

BB-kod är
Smilies är
[IMG]-kod är
HTML-kod är av
Forumhopp



Alla tider är GMT +2. Klockan är nu 20:34.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Svensk översättning av: Anders Pettersson
© Svenska 3D-Tåg 2001-2009