Svenska 3D-Tåg - Forum  
 

Om det här är ditt första besök, se till att gå till vår FAQ (finns även länk till FAQ i navigeringsmenyn ovan). Du kan behöva att registrera dig innan du kan posta (finns även en länk till registrering i navigeringsmenyn ovan). För att titta på inlägg, välj det forum som du vill besöka från de som är listade nedan.

Gå tillbaka   Svenska 3D-Tåg - Forum > Auran Trainz > Scenarios och scripts

Svara
 
Ämnesverktyg Visningsalternativ
Gammal 2020-02-14, 15:59   #1
hgkn
Medlem
 
Reg.datum: Mar 2003
Ort: Hässelby Vst, Sweden.
Inlägg: 749
Standard HB problem

Efter uppdatering TANE till sp 4 built 105766 fungerar inte tavlorna. På bilden origenterings tavla.
Bifogade bilder
Filtyp: jpg HB.JPG (85.5 KB, 121 visningar)
__________________
hgkn@bahnhof.se
hgkn besöker inte forumet just nu  
Svara med citat
Gammal 2020-02-15, 10:19   #2
NEBO
Medlem
 
Reg.datum: Mar 2011
Ort: Järfälla
Inlägg: 84
Standard

För mig fungerar tavlor, vägskydd och signaler.
__________________
nebo
NEBO besöker inte forumet just nu   Svara med citat
Gammal 2020-02-15, 11:50   #3
Tjatte
Medlem
 
Reg.datum: Dec 2004
Ort: , , Sweden.
Inlägg: 217
Skicka ett meddelande via MSN till Tjatte
Standard för mig också

dom funker för mig också
Tjatte besöker inte forumet just nu   Svara med citat
Gammal 2020-02-17, 14:18   #4
blomsson
Medlem
 
Reg.datum: Jul 2011
Ort: Vingåker
Inlägg: 281
Standard

Jag har inte tillgång till någon uppdatering ännu för min build av T:ANE, så därför kan jag inte testa om det finns några problem!
Men jag är ganska övertygad om att det inte är problem med just mina objekt!

I en tidigare tråd (Allt försvann) från mitten av Januari beskriver och visar du, hgkn, liknande problem med STL:s objekt, jag har också sett tidigare inlägg från dig med liknande problem där objekten är "borta" och endast en orange figur visas.

Under mina år med Trainz och då framförallt med T:ANE har jag aldrig upplevt att det har sett ut som du beskriver, och jag vill dessutom drista mig till att påstå att jag bara har sett de orangea figurerna i dina inlägg.

Detta får mig att fundera på om det är något "lurt" hos dig?
Den orangea kuben verkar vara en visuell representation av objektets volym, sedan kan objektet ju flyttas utanför kuben via script.
Eftersom kuben finns så bör ju också objektens position finnas i spelat, då uppstår några frågor:

Fungerar objekten ändå?
Kan du påverka objekten, flytta dom, öppna propertyrutan osv?
Är några objekt eller bibliotek osv, faulty?
Har du testat en "rebuild database"?

Att installera om objekt ska inte behövas, även om det skulle kunna fixa saker, eftersom problemet troligtvis inte ligger hos objekten!

Det skulle vara intressant att veta om det är fler som har sett de orangea kuberna i något sammanhang?

mvh
Håkan
__________________
Fd. signalreparatör på Banverket. Sjukpensionär bla pga Aspergers syndrom.
Använder numera T:ANE på en iMac (Retina, 27", -15), 24GB, OSX Sierra 10.12.6 (25/9-17)
Hemsida för nedladdning av mina objekt: https://blomsson4073.se/index.html
blomsson besöker forumet just nu   Svara med citat
Gammal 2020-02-19, 15:22   #5
hgkn
Medlem
 
Reg.datum: Mar 2003
Ort: Hässelby Vst, Sweden.
Inlägg: 749
Unhappy Eländes elände.

Det måste vara något knas i min installation. Rebuilt har jag gjort, någon propertyruta finns inte och hur mycket jag än klickar där kuben bör finnas så händer inget och eftersom dom orange figurerna syns i drive fick jag köra delete missing assets.
Jag får nog ominstallera för nu funkar nästan inga ånglok heller.
Så här ser i varje fall felmeddelandet ut. (Usch vad jag blir deppig)
Bifogade bilder
Filtyp: jpg hb2.JPG (97.9 KB, 82 visningar)
__________________
hgkn@bahnhof.se
hgkn besöker inte forumet just nu   Svara med citat
Gammal 2020-02-19, 17:26   #6
blomsson
Medlem
 
Reg.datum: Jul 2011
Ort: Vingåker
Inlägg: 281
Standard

Efter att ha sett felmeddelandet så kan det vara både knas med installationen (eller något annat hos dig) men också något som har förändrats i kraven hos funktionerna. Felmeddelandet betyder att en specifik funktion som måste ha anropats inte har gjort så och det stämmer med hur koden är skriven. Koden följer dock så som de själva har gjort emellanåt, men det är ju inte otroligt att de har ändrat kraven på koden och lagt in extra kontroller.
Det som är konstigt med felmeddelandet är att raderna som det hänvisas till är mitt i for-slingor, borde vara mer logiskt att det saknade anropet påkallades först eller sist i funktionen, men TrainzScript (Trainz) är allt annat än logiskt i många fall!!

Men om det är det felmeddelandet som orsakar problemen så borde alla som använder HB Tavelpaket under T:ANE SP4 få samma problem. Jag vet ju inte hur många, om ens någon, förutom du som använder mina grejer.
Så för er NEBO, Tjatte och eventuellt andra, använder ni HB Tavelpaket under T:ANE SP4 och hur fungerar det?

De orange figurerna har ju du visat långt innan SP4 så min teori är att de egentligen bara visar "att här var det ett objekt som nu inte finns eller som det är problem med", när jag har något objekt som är faulty så syns det inte alls och kan därför inte manipuleras, och så som du beskriver det verkar det vara samma beteende.

Eftersom jag ännu inte har någon egen SP4 så kan jag inte kolla vad som felas.

Däremot så kan jag säga att en uppdatering av Scriptbiblioteket kommer att ske när en uppdatering av Balisgruppen släpps i samband med Vägskyddet, tanken var att släppa Balisgruppen efter vägskyddet men om det finns något fel i biblioteket så kanske jag får ompröva ordningen när objekten släpps.

mvh
Håkan
__________________
Fd. signalreparatör på Banverket. Sjukpensionär bla pga Aspergers syndrom.
Använder numera T:ANE på en iMac (Retina, 27", -15), 24GB, OSX Sierra 10.12.6 (25/9-17)
Hemsida för nedladdning av mina objekt: https://blomsson4073.se/index.html

Senast redigerad av blomsson den 2020-02-19 klockan 17:31.
blomsson besöker forumet just nu   Svara med citat
Gammal 2020-02-20, 07:16   #7
hgkn
Medlem
 
Reg.datum: Mar 2003
Ort: Hässelby Vst, Sweden.
Inlägg: 749
Smile

Tack för din utmärkta beskrivning för mig som inte kan något om programmering.
__________________
hgkn@bahnhof.se
hgkn besöker inte forumet just nu   Svara med citat
Gammal 2020-03-10, 16:48   #8
blomsson
Medlem
 
Reg.datum: Jul 2011
Ort: Vingåker
Inlägg: 281
Standard

Nu har även jag, sedan några dagar tillbaka, uppgraderat till T:ANE Sp4 (build 105765).
Mina misstankar bekräftades därmed, att N3V har lagt in kontroller/krav på att vissa funktioner måste anropa Inherited() någonstans inom funktionen. Utan att gå in på för mycket detaljer så kan man säga att en vits med så kallad objekt orienterad programmering är att man kan återanvända kod istället för att skriva nytt för varje typ av objekt som ska programmeras. Det innebär att senare konstruerade objekt kan använda sig av (ärva, eng inherit) tidigare objekts kod (funktioner, variabler mm). För att säkerställa det så tycker N3V att man måste anropa Inherited(), därför de nya kraven.

Detta är nu åtgärdat, och jag upptäckte också att jag hade gjort samma sak på flera ställen i vägskyddssystemet.

När jag testade fick jag exakt samma felmeddelande, men några orangea kuber fick jag inte utan objekten saknades bara.

Ett litet exempel för de som är intresserade:
Vi ska skapa lite kod för några fordon, så vi skapar en basklass (i Trainz class Fordon) där vi definierar variabler som innehåller information om t.ex:
  • Antalet hjul
  • Färg
  • Ägare
  • Märke
  • Osv
Sedan skapar vi funktioner för att kunna manipulera och hämta informationen vi är intresserade av.
Men nu är det ju så att en bil inte är samma som en cykel eller buss.

Då skapar vi så kallade "child classes" eller barnklasser om man så vill, de kan kallas lite olika beroende på vilket programmeringsspråk man använder, men principen är den samma.

Så vi skapar en klass för Bilar:
  • Typ av växellåda
  • 4WD
  • Dragkrok
  • Regnummer
  • Osv

Och en för Cyklar:
  • Antalet växlar
  • Cykeltyp
  • Pakethållare
  • Typ av styre
  • Osv

Både Bilar och Cyklar kan man då få att ärva samtliga variabler och funktioner från tidigare klasser, det görs i Trainz genom att skriva class Bilar (eller Cyklar) isclass Fordon.
Sedan kan man hålla på att bygga ut det här i oändlighet, man kan också ärva från flera klasser, i Trainz finns det vissa restriktioner hur man kan ärva mellan klasserna.
Sedan finns det en del andra finesser en del beroende på programmeringsspråk.

Hoppas hgkn ursäktar den lilla utflykten från ämnet!

Nu åter till verkligheten!
När jag kollade lite efter Sp4 uppgraderingen upptäckte jag även ett annat fel, detta rör dubbelriktade länkade Hastighetstavlor, där den dubbelriktade pilen saknas och B-balisens information saknas när propertyrutan åter öppnades. Detta innebär att man inte kan förändra den länkade hastighetstavlan på annat vis än att ta bort den, men felet kommer att återuppstå vid nya försök.
Ett följdfel är att länkade Orienteringstavlor mot dubbelriktade Hastighetstavlor inte visar några baliser, en omlänkning verkar inte hjälpa!
Om båda dessa fel beror på förändringen i databasen som jag behövde göra i.o.m. uppdateringen till Sp4 eller om det var så tidigare, vet jag ej. Jag har tyvärr ingen möjlighet att testa under Sp3 beroende på platsbrist.
Om det är någon som använder mitt tavelpaket under T:ANE Sp3 och vill testa så går det att skicka PM!

Samtliga hittade fel är åtgärdade.
Om man har Sp3 och använder mitt system avvakta att uppgradera till Sp4, för er som redan har uppgraderat och inte vill radera utplacerade objekt är det bara att vänta!

Jag har tagit en paus med vägskyddet och koncentrerar mig på att göra iordning Balisgruppen (som ju är vägskyddsrelaterat) eftersom den också innehåller förändringar i samma bibliotek som felen. Jag tror inte att det ska behöva ta mer en någon vecka att fixa, skulle jag se att det drar ut på tiden så kommer jag att släppa en uppdatering tidigare för bara felen!
Började med Balisgruppen igår och hittills går det bra...

mvh
Håkan
__________________
Fd. signalreparatör på Banverket. Sjukpensionär bla pga Aspergers syndrom.
Använder numera T:ANE på en iMac (Retina, 27", -15), 24GB, OSX Sierra 10.12.6 (25/9-17)
Hemsida för nedladdning av mina objekt: https://blomsson4073.se/index.html
blomsson besöker forumet just nu   Svara med citat
Gammal 2020-03-20, 11:52   #9
blomsson
Medlem
 
Reg.datum: Jul 2011
Ort: Vingåker
Inlägg: 281
Standard

Uppdatering finns nu på hemsidan!

Går att läsa mera här:
http://www.e-buzz.se/forum/showthrea...386#post316386

mvh
Håkan
__________________
Fd. signalreparatör på Banverket. Sjukpensionär bla pga Aspergers syndrom.
Använder numera T:ANE på en iMac (Retina, 27", -15), 24GB, OSX Sierra 10.12.6 (25/9-17)
Hemsida för nedladdning av mina objekt: https://blomsson4073.se/index.html
blomsson besöker forumet just nu   Svara med citat
Svara

Ämnesverktyg
Visningsalternativ

Regler för att posta
Du får inte posta nya ämnen
Du får inte posta svar
Du får inte posta bifogade filer
Du får inte redigera dina inlägg

BB-kod är
Smilies är
[IMG]-kod är
HTML-kod är av
Forumhopp



Alla tider är GMT +2. Klockan är nu 02:17.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Svensk översättning av: Anders Pettersson
© Svenska 3D-Tåg 2001-2009