Svenska 3D-Tåg - Forum  
 

Om det här är ditt första besök, se till att gå till vår FAQ (finns även länk till FAQ i navigeringsmenyn ovan). Du kan behöva att registrera dig innan du kan posta (finns även en länk till registrering i navigeringsmenyn ovan). För att titta på inlägg, välj det forum som du vill besöka från de som är listade nedan.

Gå tillbaka   Svenska 3D-Tåg - Forum > N3V Trainz > Scenarios och scripts

Svara
 
Ämnesverktyg Visningsalternativ
Gammal 2020-12-08, 20:57   #1
korvtiger
Medlem
 
Reg.datum: Jan 2008
Ort: Uppland, Sverige
Inlägg: 2 650
Standard STL och TRS2019 - frågetråd

Som ni kanske har sett är Svenolov tillbaka till Trainz:andet och ska förhoppningsvis sätta lite fart på STLs övergång till TRS2019!
Jag skapar denna tråd för att ni ska kunna ställa frågor om hur vi tänker, vad vi planerar och så vidare vad det gäller STLs assets.

Våra närmaste planer är i alla fall först och främst att få STL-koppel att fungera tillfredsställande i TRS2019. Därefter kommer vi att fortsätta med att uppdatera signalscripten, vilka vad jag förstår det som inte alls fungerar i TRS2019. Vi har inte bestämt helt hur vi ska göra, men vi kommer nog att välja att fokusera på den äldre signaleringsprincipen (alltså med semaforer och de äldre ljussignalerna).

Vi har också funderat och kommer nog att utveckla scripten för att fungera i TRS2019, vilket också bör fungera i (åtminstone den nyaste SP-uppdateringarna av) TANE. De gamla versionerna av STL-scriptbiblioteken som finns nu kommer naturligtvis att finnas kvar på hemsidan för de av er som av olika anledningar vill hålla er till de äldre utgåvorna av Trainz!


Så, finns det några frågor eller önskemål?
__________________
-k-
korvtiger besöker inte forumet just nu  
Svara med citat
Gammal 2020-12-08, 22:24   #2
benkegbg
Medlem
 
Reg.datum: Feb 2005
Ort: Fort McMurray, Alberta, CANADA
Inlägg: 1 381
Standard

Hej!
Jag tror att Vägskydd troligen är nästa punkt på listan? Efter sematorer och gammalt så är det nog också de vanligaste signalerna, som används till vägskydden.
Det märkliga är att vägskydd-systemet fungerade till en början i TRS19, men inte nu längre. Tror deras funktion försvann vid uppatchning senare.
Förstår att ni har mycket jobb framför er och ser med djup tacksamhet fram emot att få använda STL-s fina objekt längre fram.
Hälsningar
__________________
Benkegbg
Är president i Bensland. Ett land där ALLA älskar att åka tåg.
benkegbg besöker inte forumet just nu   Svara med citat
Gammal 2020-12-09, 03:54   #3
Hawk
Veteran
 
Reg.datum: Aug 2001
Ort: Mölndal
Inlägg: 4 267
Standard

__________________

Hawk besöker inte forumet just nu   Svara med citat
Gammal 2020-12-09, 13:26   #4
NEBO
Medlem
 
Reg.datum: Mar 2011
Ort: Järfälla
Inlägg: 106
Standard

Jag har Trainz i två datorer. Den med Build 105766 fungerar signaler och vägskydd alldeles utmärkt.
Datorn med Build 105096 fungerar vägskydd och signaler som fanns innan uppdateringen, men det går inte att lägga in nya vägskydd.
__________________
nebo
NEBO besöker inte forumet just nu   Svara med citat
Gammal 2020-12-09, 17:16   #5
tanigardi
Medlem
 
Reg.datum: Nov 2009
Ort: Gävle
Inlägg: 123
Standard

Har gjort en test med smalspårskoppel, dvs koppel, slutsignal och slutsignalshållare (en PBR-version) och scriptet fungerar i trainz 19 precis som i Tane. Vad som gjort att Stl-kopplen inte fungerat till 4.6 objekt visade sig vara att i och med version 4.5 och högre måste alla ingående mesher dela samma material, annars så fungerar det inte och visas faulty i CM. Det medför ju att alla mesherna måste textureras om och medför ju en hel del jobb även om "procedural texturing" gör det hela lite snabbare och smidigare.
tanigardi besöker inte forumet just nu   Svara med citat
Gammal 2020-12-15, 21:38   #6
korvtiger
Medlem
 
Reg.datum: Jan 2008
Ort: Uppland, Sverige
Inlägg: 2 650
Standard

Vägskydden vill nog Svenolov vidareutveckla också!

NEBO: Detta tolkar jag då som att vägskydden först fungerade fint i TRS2019, men att något i Trainz fick dem att sluta att fungera i 105096 för att sedan fungera fint i 105766 igen? Det låter ju lovande att de fungerar igen i alla fall. Vi har inte hunnit undersöka hur väl signalsystemet fungerar i TRS2019 än, så vi får se längre fram om någonting behöver åtgärdas och hur.

Tanigardi: Problemen med STL-koppel NG kommer jag ihåg att du har skrivit om. Anledningen till det var väl att jag fick nöd-LOD:a STL-koppel NG för att få den att fungera i senare versioner av TANE. Men jag gjorde dem ju i Blender istället för 3DsMax som Lan har använt, så det blev ett annorlunda material. Det är möjligt att det går att lösa med lite trixande genom att matcha LOD:ningens material med Lans original. Kan se om jag får tid att kika på det.
Hur har du löst det hela idag? Har du skapat ett eget koppel-bibliotek?
__________________
-k-
korvtiger besöker inte forumet just nu   Svara med citat
Gammal 2020-12-16, 06:54   #7
benkegbg
Medlem
 
Reg.datum: Feb 2005
Ort: Fort McMurray, Alberta, CANADA
Inlägg: 1 381
Standard

Citat:
Ursprungligen postat av NEBO Visa inlägg
Jag har Trainz i två datorer. Den med Build 105766 fungerar signaler och vägskydd alldeles utmärkt.
Datorn med Build 105096 fungerar vägskydd och signaler som fanns innan uppdateringen, men det går inte att lägga in nya vägskydd.
Kanske ett förtydligande är på plats? Build 105766 är Trainz New Era (TANE) SP 4 och Build 105096 är Trainz Simulator 2019.

Det är då så att i TANE (Build 105766) fungerar allt, men i TRZ19 (Build 105096) fungerar det inte!

Det mest märkliga (!) är att om jag öppnar exempelbana i Trainz 2019 så syns propertyrutorna med all information. (se bild).
Men - om jag vill sätta ut nya signaler så är propertyrutorna tomma (unassigned).
Bifogade bilder
Filtyp: jpg Propertyruta.jpg (117.8 KB, 149 visningar)
__________________
Benkegbg
Är president i Bensland. Ett land där ALLA älskar att åka tåg.

Senast redigerad av benkegbg den 2020-12-16 klockan 06:55.
benkegbg besöker inte forumet just nu   Svara med citat
Gammal 2020-12-16, 17:43   #8
tanigardi
Medlem
 
Reg.datum: Nov 2009
Ort: Gävle
Inlägg: 123
Standard

Korvtiger: kopplet har jag löst med ett bibliotek enl. STL's modell. Det var en liten snabbfix så jag kunde få koppel, slutsignaler och slutsignalhållare till mina PBR-vagnar. Så biblioteket innehåller bara 3 mesher, men tanken är väl att bygga ut det med åtminstone luftslangar och kanske någon mer typ av smalspårskoppel och eventuellt även Sharfenberg-kopplet. Kopplet jag gjort hittills är anpassat så det fungerar hyfsat med Lan's motsvarande koppel. Har ett program som kan läsa in IM-filer, så jag kunnat hitta de kritiska måtten. Mesherna har jag dock gjort från scratch.
tanigardi besöker inte forumet just nu   Svara med citat
Gammal 2020-12-18, 12:42   #9
korvtiger
Medlem
 
Reg.datum: Jan 2008
Ort: Uppland, Sverige
Inlägg: 2 650
Standard

Citat:
Ursprungligen postat av benkegbg Visa inlägg
Kanske ett förtydligande är på plats? Build 105766 är Trainz New Era (TANE) SP 4 och Build 105096 är Trainz Simulator 2019.

Det är då så att i TANE (Build 105766) fungerar allt, men i TRZ19 (Build 105096) fungerar det inte!

Det mest märkliga (!) är att om jag öppnar exempelbana i Trainz 2019 så syns propertyrutorna med all information. (se bild).
Men - om jag vill sätta ut nya signaler så är propertyrutorna tomma (unassigned).
Tack för förtydligandet!

Unassigned, betyder inte det bara att mastern inte är ihopkopplad med någon scenery signal än? Eller menar du att den fortsätter att vara unassigned även när de ska vara ihopkopplade med hjälp av namnet?

Jag har testat mina exempelbanor i TRS2019 Ultimate (build 105100). Där så är signalerna oinitialiserade och reagerar inte när man är i Surveyor, men de verkade hoppa igång och fungera hjälpligt, åtminstone ett tag, i driver. Jag fick några script exceptions som vi behöver kolla på. Jag testade däremot inte att sätta ut nya signaler. Men det skulle kunna vara av samma anledning som det inte fungerar att sätta ut nya signaler, att själva signalscriptet inte har startat ordentligt.

Tanigardi:
Jag kanske kan se om jag kan fixa lod-mesherna. I annat fall, skulle du vilja bidra med dina mesher till STL-NG-biblioteket?
__________________
-k-
korvtiger besöker inte forumet just nu   Svara med citat
Svara

Ämnesverktyg
Visningsalternativ

Regler för att posta
Du får inte posta nya ämnen
Du får inte posta svar
Du får inte posta bifogade filer
Du får inte redigera dina inlägg

BB-kod är
Smilies är
[IMG]-kod är
HTML-kod är av
Forumhopp



Alla tider är GMT +2. Klockan är nu 14:37.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.
Svensk översättning av: Anders Pettersson
© Svenska 3D-Tåg 2001-2009