Svenska 3D-Tåg - Forum  
 

Om det här är ditt första besök, se till att gå till vår FAQ (finns även länk till FAQ i navigeringsmenyn ovan). Du kan behöva att registrera dig innan du kan posta (finns även en länk till registrering i navigeringsmenyn ovan). För att titta på inlägg, välj det forum som du vill besöka från de som är listade nedan.

Gå tillbaka   Svenska 3D-Tåg - Forum > Auran Trainz > 3D-design - Trainz

Svara
 
Ämnesverktyg Visningsalternativ
Gammal 2019-10-09, 16:21   #1
tanigardi
Medlem
 
Reg.datum: Nov 2009
Ort: Gävle
Inlägg: 55
Standard STL-koppel fungerar ej till assets version 4.5 eller högre

Har färdigställt mitt första riktiga PBR-projekt (version 4.6), en godsvagn. Problemet är att när man lägger till kopplen i configen och "submittar", kommer följande felmeddelande upp.

koppel_errors.jpg

När jag läst om VE186, så framgår det att assets (4.5 och högre) som använder attachments som är del av en asset som tillämpar "Material sharing", endast får referera till ett material som är exakt lika, d.v.s. felet kan uppstå om materialet refererar till olika texturer i skilda mesher.

Från NV3:

"The following examples will result in a warning/error.

An asset uses the same material name for three different LOD meshes. Two meshes are exported with one version of the material but the last is exported with a variation, such as a different material specular value.

As for the first example, but a texture is substituted, added or removed, for one of the meshes.

As for the first example, but the two conflicting meshes are generic meshes (eg, an attachment mesh and a shadow mesh) that use the same material name and the materials in the two meshes have different property values. The error is reported even though there is no texture resource for the material.

An asset is created with two meshes both within their own source file. The same notex material name is used for both meshes but there is a variation in the diffuse colour.

Therefore:

Do not use the same material name if the materials should have different parameters.
If you use the same material name in different meshes then ensure that the material parameters are the same.
Avoid material names (eg 'black_m') that are common in generic meshes that might subsequently be added to the asset. "


Nu är ju problemet att felet inte kan åtgärdas i "Content Manager" utan endast av skaparen av objekten. Min undran är om det finns någon som kan eller har lust att fixa problemet, annars blir det väl till att jag får försöka att göra någon egen variant av animerade koppel (åtminstone smalspårsversionen). Vore ju synd för STL-kopplen är ju väldigt välgjorda och förhoppnigsvis så kommer det fler byggare som gör PBR-assets till trs19.

Åke
tanigardi besöker inte forumet just nu  
Svara med citat
Gammal 2019-10-15, 18:50   #2
korvtiger
Medlem
 
Reg.datum: Jan 2008
Ort: Östergötland, Sverige
Inlägg: 2 483
Standard

Kul att du experimenterar med PBR!

Kopplen är gjorda av Lan och han har tyvärr inte längre tillgång till 3D-filerna till dessa koppel efter ett diskhaveri för ett par år sedan.
Jag fixade ju LOD på STL-koppel NG för ett par år sedan. I det fallet fick jag mesher av Lan som hade något program för att omvandla .im filer till något vanligt 3D-format. Ifrån dessa (oanimerade) mesher kunde jag sedan skapa LOD-mesher på flera olika nivåer. Eftersom jag har använt Blender och Lan körde 3DsMax är det näsan säkert att materialinställningarna varit olika, programmen emellan. Därav felet.

Jag har inte och kommer tyvärr inte ha tillgång till min gamla Trainz-dator, så jag kan nog tyvärr inte hjälpa dig att fixa STLs koppelbibliotek är jag rädd.
Men jag föreslår två sätt du kan lösa det hela på:
1. Att du gör en temporär fix, genom att du klonar STL-koppel NG och byter ut mina LOD-mesher till några egna som bara är någon polygon som syns när kopplet är jääääättelångt borta. Detta gör ju prestandan sämre jämfört med min LODning. Du kan få till samma material som i Lans LOD0-mesh genom att granska denna i Trainz Mesh Viewer (http://trainz.shaneturner.co.uk/tuto...-mesh-viewer-2) där alla inställningarna på materialen kan visas. Då kan du försöka exportera från Blender och få till samma material-inställningar. Alternativt kan du använda en egen textur till din LOD-mesh, och då är problemet löst.
2. Du gör ett eget koppelbibliotek. Detta är nog det jag skulle rekommendera på lång sikt, då varken jag eller Lan är särskilt aktiva längre och kan fixa de fel som uppstår i STLs koppel-bibliotek. Jag ska försöka se om jag råkar ha Lans meshfiler på någon USB någonstans så kan jag maila dig dem om du är intresserad.
__________________
-k-
korvtiger besöker inte forumet just nu   Svara med citat
Gammal 2019-10-16, 16:49   #3
tanigardi
Medlem
 
Reg.datum: Nov 2009
Ort: Gävle
Inlägg: 55
Standard

Har redan insett att det bästa alternativet är att göra ett eget koppelbibliotek. Har hittat ett program som kan konvertera IM-filer till t.e.x. .obj som kan importeras till Blender (förmodligen samma program som lan använder). Det fungerar hyfsat, rotationen är lite uppåt väggarna, men det går ju lätt att fixa. Måtten stämmer i alla fall, däremot får man ju göra animationen från scratch. Animationen är ju ganska enkel att göra, men ett problem är ju vid vilka frames de olika lägena på kopplet skall inträffa. Är lite konfunderad, hittade en tråd på Auran's forum från 2012, startad av Bjornl:

For instance in the STL animation system that I know a bit about this is directions for a creator like this:
STL NG-couplers:
luft_0 (right air hose):
16 frames animation
frame 0 – uncoupled and hooked up
frame 15 – coupled straight

luft_1 (left air hose):
24 frames animation
frame 0 - coupled diagonally
frame 11 - uncoupled and hooked up
frame 23 - coupled straight

Couplers:
49 frames animation
frame 0 – coupled
frame 11 – uncoupled and hanging safety chains
frame 25 – coupled
frame 35 – uncoupled and safety chains hooked up
frame 48 - uncoupled and hanging safety chains

När jag studerar msvehicle så har jag hitta följande som jag gissar anger de olika "animationslägena":

include "World.gs"
include "Train.gs"
include "Vehicle.gs"
include "MSMotorVehicle.gs"
include "TrainUtilities.gs"

//************************************************** ************************************************** *

class MsVehicle isclass Vehicle
{
define bool DEBUG = false;
define float TICK = 1.0;
define string NULL = "NULL";

public define bool FRONT = true;
public define bool REAR = false;

public define int NONE = -1;
public define int LEFT = 0;
public define int RIGHT = 1;
public define int CROSS = 2;
public define int STATIC = 2;

define int UPPHANGD = 0;
define int KOPPLAD = 1;
define int DRAGKROK = 2;
define int HANGANDE = 3;

define int STL_UPPHANGD = 0;
define int STL_HANGANDE_1 = 12;
define int STL_KOPPLAD = 25;
define int STL_DRAGKROK = 37;
define int STL_HANGANDE_2 = 49;

Så nu är min undran om jag uppfattat msvehicle rätt och att uppgifterna i Bjornl's tråd inte stämmer.

Har redan börjat göra ett litet koppelbibliotek med "koppel_up, skärmar och slutsignalhällare. Har animerat kopplet enl. uppgifterna i Bjornl's tråd, och textureringen av kopplet är klar.

Blender 2.8 är verkligen ett lyft, mycket mer intuitivt att arbeta med. Har börjat med "procedural texturing" (tror att det heter så) och med Eevee render kan man ju se resultatet i realtid. Med en addon som heter Mask Tools (35:-$) så fungerar textureringen i princip som med Substance Painter, bara med skillnaden att man arbetar med noder i stället för lager. Att det finns massor med fria PBR-material att ladda hem gör ju inte saken sämre. Det räcker i princip med att använda "smart UV-unvrap", så textureringen går ju som en dans.

Åke
tanigardi besöker inte forumet just nu   Svara med citat
Gammal 2019-10-16, 17:46   #4
korvtiger
Medlem
 
Reg.datum: Jan 2008
Ort: Östergötland, Sverige
Inlägg: 2 483
Standard

Vad bra! Allt detta blir säkert lättare i framtiden när Trainz övergår till FBX-formatet, som vem som helst kan öppna i efterhand (på gott och ont...)

Jag skulle ju tro mer på MsVehicle.gs i detta fall. Det låter mer rimligt att animationen börjar på upphängd och inte kopplad. Det är ju denna pose som kopplet intar när man sätter ut ett fordon. Ett enkelt sätt att kolla är ju att göra en liten sceneryasset med kopplets mesh och animation och sätta den på att loopa animationen långsamt. Då kan du ju enkelt se vilken ordning poserna kommer i. Dock kan det vara svårt att se vilken som är första posen, men det borde gå att lösa genom att ta bort animationen på meshen, då torde den inta första posen. I fallet NG-koppel tror jag att vissa av dessa poser är samma, då man inte kan ha kopplet hängande eller kopplat på egen koppelkrok likt normalspårskopplet. Du får kolla Lans animation!

Björnl kan ju ha rätt, bara att vi gjort om animationen någon gång och att han kollat på en äldre variant av det hela.

Mask tools kände jag inte till, men det verkar väldigt användbart! Alltid kul när man kan göra textureringen både snabbare och smartare! Dessa features kommer nog att implementeras på ett eller annat sätt direkt i Blender i framtiden, men tur att det finns addons att tillgå så länge! Har verkligen saknat dessa features i Blender och sneglat en del på Substance Painter.
__________________
-k-
korvtiger besöker inte forumet just nu   Svara med citat
Gammal 2019-10-16, 18:41   #5
blomsson
Medlem
 
Reg.datum: Jul 2011
Ort: Vingåker
Inlägg: 261
Standard

Citat:
Ursprungligen postat av korvtiger Visa inlägg
Vad bra! Allt detta blir säkert lättare i framtiden när Trainz övergår till FBX-formatet, som vem som helst kan öppna i efterhand (på gott och ont...)
Fast det är ju inte FBX-filen som är det objekt som Trainz arbetar med utan trainzmesh (sedan version 4.5) som skapas automatiskt av Trainz från FBX-filen och som motsvarar im, vilket innebär att om inte själva FBX-filen finns medskickad hos asseten så blir det ju samma "problem" som med im filen.

Jag personligen skickar inte med några FBX-filer i mina alster, vilket i huvudsak beror på att jag vill ha kontroll på mina egna objekt!

mvh
Håkan
__________________
Fd. signalreparatör på Banverket. Sjukpensionär bla pga Aspergers syndrom.
Använder numera T:ANE på en iMac (Retina, 27", -15), 24GB, OSX Sierra 10.12.6 (25/9-17)
Hemsida för nedladdning av mina objekt: https://blomsson4073.se/index.html
blomsson besöker forumet just nu   Svara med citat
Gammal 2019-10-18, 12:32   #6
korvtiger
Medlem
 
Reg.datum: Jan 2008
Ort: Östergötland, Sverige
Inlägg: 2 483
Standard

Citat:
Ursprungligen postat av blomsson Visa inlägg
Fast det är ju inte FBX-filen som är det objekt som Trainz arbetar med utan trainzmesh (sedan version 4.5) som skapas automatiskt av Trainz från FBX-filen och som motsvarar im, vilket innebär att om inte själva FBX-filen finns medskickad hos asseten så blir det ju samma "problem" som med im filen.

Jag personligen skickar inte med några FBX-filer i mina alster, vilket i huvudsak beror på att jag vill ha kontroll på mina egna objekt!

mvh
Håkan
Aha, då har jag inte läst dokumentationen tillräckligt! Men det är ju bra att man kan välja om man vill dela med sig av FBX-filerna eller inte.
__________________
-k-
korvtiger besöker inte forumet just nu   Svara med citat
Svara

Ämnesverktyg
Visningsalternativ

Regler för att posta
Du får inte posta nya ämnen
Du får inte posta svar
Du får inte posta bifogade filer
Du får inte redigera dina inlägg

BB-kod är
Smilies är
[IMG]-kod är
HTML-kod är av
Forumhopp



Alla tider är GMT +2. Klockan är nu 19:44.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Svensk översättning av: Anders Pettersson
© Svenska 3D-Tåg 2001-2009